Template:VersionCompatibilityClose/sandbox

From Dolphin Emulator Wiki
Jump to: navigation, search
[edit] [purge] Template documentation

Welcome to VersionCompatibilityVersion's sandbox page

Neighboring templates

Discussion

All discussions on these experimental templates should be taken to Template talk:VersionCompatibilityVersion/sandbox

About

This template is part of a set that enable a graphic display of Dolphin version compatibility.

Example

{{VersionCompatibility/sandbox}}
{{VersionCompatibilityVersion/sandbox|5370|****|}}
{{VersionCompatibilityVersion/sandbox|2.0|**|}}
{{VersionCompatibilityVersion/sandbox|6461|****|}}
{{VersionCompatibilityVersion/sandbox|3.0|****|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|3.0-461|***|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|3.5|*|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|3.5-400|****|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|3.5-420|**|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|4.0.2|***|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|4.0-2729|****|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|4.0-2800|****|Notes on this section}}
{{VersionCompatibilityVersion/sandbox|4.0-6800|*****|Notes on this section}}
{{VersionCompatibilityClose/sandbox}}

Produces

The graph below charts the compatibility with sandbox, listing revisions only where a compatibility change occurred.

PLAYABLE
r5370
INTRO
2.0
PLAYABLE
r6461
3.0
STARTS
3.0-461
BROKEN
PLAYABLE
INTRO
STARTS
PLAYABLE
PERFECT
BROKEN
Δ
5.0-11229 (current)
Δ
Δ
Δ
Δ
Δ
2.0 (r5384)
Compatibility can be assumed to align with the indicated revisions. However, compatibility may extend to prior revisions or compatibility gaps may exist within ranges indicated as compatible due to limited testing. Please update as appropriate.

Quirks

Test Auto-sizing to last populated revision. Also note the revisions are being shifted erratically.

The graph below charts the compatibility with sandbox, listing revisions only where a compatibility change occurred.

PLAYABLE
INTRO
STARTS
PLAYABLE
PERFECT
BROKEN
Δ
5.0-11229 (current)
Δ
Δ
Δ
Δ
Δ
2.0 (r5384)
Compatibility can be assumed to align with the indicated revisions. However, compatibility may extend to prior revisions or compatibility gaps may exist within ranges indicated as compatible due to limited testing. Please update as appropriate.

Add these null vardefines before the next Version Compatibility table to clear out the old values before loading into next table:

{{#vardefine:rev|}}{{#vardefine:last|}}{{#vardefine:lastrev|}}{{#vardefine:lastrev2|}}

Result

The graph below charts the compatibility with sandbox, listing revisions only where a compatibility change occurred.

PLAYABLE
INTRO
STARTS
PLAYABLE
PERFECT
BROKEN
Δ
5.0-11229 (current)
Δ
Δ
Compatibility can be assumed to align with the indicated revisions. However, compatibility may extend to prior revisions or compatibility gaps may exist within ranges indicated as compatible due to limited testing. Please update as appropriate.

Another quirk is that the closing template will not reload with the null variables until it's given with a pipe character (which is also in place in the result above).

Guidelines

  • Two parameters are required, the first is the revision a compatibility change occurred on. The second the compatibility rating achieved with that revision.
  • There shouldn't be another "Perfect" bar if the latest revision tested already has "Perfect" bar.