Template:VersionCompatibility

From Dolphin Emulator Wiki
Jump to: navigation, search
[edit] [purge] Template documentation

About

This template is part of a set that enable a graphic display of Dolphin version compatibility.

Neighboring templates

Example

{{VersionCompatibility}}
{{VersionCompatibilityVersion|2.0|**|Notes on this section}}
{{VersionCompatibilityVersion|6461|****|Notes on this section}}
{{VersionCompatibilityVersion|3.0-461|***|Notes on this section}}
{{VersionCompatibilityVersion|3.5|*|Notes on this section}}
{{VersionCompatibilityVersion|3.5-400|**|Notes on this section}}
{{VersionCompatibilityVersion|4.0.2|***|Notes on this section}}
{{VersionCompatibilityVersion|4.0-2729|*****|Notes on this section}}
{{VersionCompatibilityClose}}

Produces

The graph below charts the compatibility with VersionCompatibility since Dolphin's 2.0 release, listing revisions only where a compatibility change occurred.

Δ
5.0-9211 (current)
Δ
Δ
Δ
Δ
Δ
2.0 (r5384)
Compatibility can be assumed to align with the indicated revisions. However, compatibility may extend to prior revisions or compatibility gaps may exist within ranges indicated as compatible due to limited testing. Please update as appropriate.

Notes

  • Two parameters are required, the first is the revision a compatibility change occurred on. The second the compatibility rating achieved with that revision.
  • There is a residual issue with the widths of low revisions (0-1000). These are set to 100% width or close to but for some reason still exceed the width of their container.